CompoundStructureGetLayerAssociatedToRegion Method |
Gets the layer associated to a particular region.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int GetLayerAssociatedToRegion(
int regionId
)
Public Function GetLayerAssociatedToRegion (
regionId As Integer
) As Integer
public:
int GetLayerAssociatedToRegion(
int regionId
)
member GetLayerAssociatedToRegion :
regionId : int -> int
Parameters
- regionId Int32
-
The id of a region.
Return Value
Int32
The index of a layer in this CompoundStructure.
ExceptionsException | Condition |
---|
ArgumentsInconsistentException |
For a non-vertically compound structure, implicitly each layer is associated to its corresponding simple region.
|
See Also