BuiltInFailuresDPartFailures Class

Failures related to parts.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresDPartFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class DPartFailures

The BuiltInFailuresDPartFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberBindLinkWillDeleteAllPartsWarning Bind Link will delete its associated Parts.
Public propertyStatic memberDeletingDPartWillDeleteAllPartsWarning Deleting a Part will delete all associated Parts and the original Element will be made visible.
Public propertyStatic memberDeletingDPartWillDeleteMorePartsError Deleting a Part will delete all associated Parts and the original Element will be made visible.
Public propertyStatic memberDeletingOriginalWillDeleteParts Deletion of this element will delete its associated Parts.
Public propertyStatic memberDivideVolumesProfilesEdgeMatchForWidthAll Division family cannot be used with the selected edge condition for all widths of hosts
Public propertyStatic memberDivideVolumesProfilesEdgeMatchForWidthSome Division family cannot be used with the selected edge condition for some widths of hosts
Public propertyStatic memberDivideVolumesProfilesForWidthAll Division family cannot be used for all widths of hosts
Public propertyStatic memberDivideVolumesProfilesForWidthSome Division family cannot be used for some widths of hosts
Public propertyStatic memberDivideVolumesProfilesGapForWidthAll Division family cannot be used with the selected division gap for all widths of hosts
Public propertyStatic memberDivideVolumesProfilesGapForWidthSome Division family cannot be used with the selected division gap for some widths of hosts
Public propertyStatic memberDivideVolumesProfilesNonSlabSources Some sources of a volume divider are non-slab like.
Public propertyStatic memberDivideVolumesSketchesWithProfileUnfriendlyCurves Sketch contains curves to which profiles cannot be applied or chains of curves.
Public propertyStatic memberDivisionContainsNoParts The division contains no parts.
Public propertyStatic memberDivisionContainsNoReferences The division contains no dividing references.
Public propertyStatic memberElementsAlreadyHaveParts Some elements already have parts
Public propertyStatic memberIneligibleElementsForParts Creating parts from ineligible elements
Public propertyStatic memberNoPartMakerCreatedInEditMode Nothing will be divided.
Public propertyStatic memberPartPhaseParametersConflictWithOriginal The creation and demolition phases of a part must lie between the corresponding phases of the original.
Public propertyStatic memberPartsCannotBeCreatedFromInvalidGeom Post failure when attempts to create parts from invalid geometry.
Public propertyStatic memberRemovingInvalidDPartParents Can't make Parts out of these Elements.
Public propertyStatic memberRemovingUndividedDPartParents These parts are not intersected by any dividing references. They will be removed from the division.
Public propertyStatic memberSourceInUnloadedLink Some elements already have parts
Top
See Also