RebarConstraintsManagerGetCurrentConstraintOnHandle Method

Retrieves the RebarConstraint that acts on the specified RebarConstraintHandle.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RebarConstraint GetCurrentConstraintOnHandle(
	RebarConstrainedHandle handle
)

Parameters

handle  RebarConstrainedHandle
 

Return Value

RebarConstraint
Exceptions
ExceptionCondition
ArgumentException handle is no longer valid.
ArgumentNullException A non-optional argument was null
InvalidOperationException The RebarConstraintsManager does not manage a valid Rebar element.
See Also