Creates a new workset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Workset Create(
Document document,
string name
)
Public Shared Function Create (
document As Document,
name As String
) As Workset
public:
static Workset^ Create(
Document^ document,
String^ name
)
static member Create :
document : Document *
name : string -> Workset
Parameters
- document Document
-
The document in which the new instance is created.
- name String
-
The workset name.
Return Value
Workset
Returns the newly created workset.
ExceptionsException | Condition |
---|
ArgumentException |
document is not a workshared document.
-or-
name is an empty string or contains only whitespace.
-or-
name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
-or-
The given workset name is already in use.
|
ArgumentNullException |
A non-optional argument was null
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
Examplepublic Workset CreateWorkset(Document document)
{
Workset newWorkset = null;
if (document.IsWorkshared)
{
string worksetName = "New Workset";
if (WorksetTable.IsWorksetNameUnique(document, worksetName))
{
using (Transaction worksetTransaction = new Transaction(document, "Set preview view id"))
{
worksetTransaction.Start();
newWorkset = Workset.Create(document, worksetName);
worksetTransaction.Commit();
}
}
}
return newWorkset;
}
Public Function CreateWorkset(document As Document) As Workset
Dim newWorkset As Workset = Nothing
If document.IsWorkshared Then
Dim worksetName As String = "New Workset"
If WorksetTable.IsWorksetNameUnique(document, worksetName) Then
Using worksetTransaction As New Transaction(document, "Set preview view id")
worksetTransaction.Start()
newWorkset = Workset.Create(document, worksetName)
worksetTransaction.Commit()
End Using
End If
End If
Return newWorkset
End Function
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also