ConstructionType Enumeration |
This enumeration specifies the available analytical construction types
like external walls, windows etc. for use in the detailed analytical
energy model.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum ConstructionType
Public Enumeration ConstructionType
public enum class ConstructionType
MembersMember name | Value | Description |
---|
ExteriorWall | 0 |
An exterior wall surrounding the space
|
InteriorWall | 1 |
An interior wall surrounding the space
|
Slab | 2 |
A slab below the space
|
Roof | 3 |
A roof over the space
|
Ceiling | 4 |
A ceiling over the space
|
Floor | 5 |
A floor below the space
|
Door | 6 |
A door in a wall in the space
|
ExteriorWindow | 7 |
A window in an exterior wall in the space
|
InteriorWindow | 8 |
A window in an interior wall in the space
|
Skylight | 9 |
A window in a roof in the space
|
UndergroundWall | 10 |
Underground walls
|
See Also