SunAndShadowSettingsGetSunrise Method |
Identifies the sunrise time for the SunAndShadowSettings element at its current location
and indicated date.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic DateTime GetSunrise(
DateTime date
)
Public Function GetSunrise (
date As DateTime
) As DateTime
public:
DateTime GetSunrise(
DateTime date
)
member GetSunrise :
date : DateTime -> DateTime
Parameters
- date DateTime
-
The date for which to determine sunrise time.
Return Value
DateTime
The date and time. The value will be in Coordinated Universal Time (UTC).
Remarks
The value returned is affected by the value of the
UsesDST
flag set for the current location. If this value is true, the sunrise value will be adjusted for
Daylight Savings Time, regardless of the value of the input date.
See Also