SchemaBuilderSetWriteAccessLevel Method

Sets top level write access (for entities)

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public SchemaBuilder SetWriteAccessLevel(
	AccessLevel writeAccessLevel
)

Parameters

writeAccessLevel  AccessLevel
Write access level value to be set

Return Value

SchemaBuilder
The SchemaBuilder object may be used to add more settings.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException The SchemaBuilder has already finished building the Schema.
See Also