ExternalDefinitionHideWhenNoValue Property |
Indicates whether this parameter should be hidden from the properties palette when it has no value.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool HideWhenNoValue { get; set; }
Public Property HideWhenNoValue As Boolean
Get
Set
public:
property bool HideWhenNoValue {
bool get ();
void set (bool value);
}
member HideWhenNoValue : bool with get, set
Property Value
Boolean
If true, the parameter will be hidden from the properties palette when it has no value.
If false, the parameter will always be shown in the properties palette, no matter if it has a value
or not.
Remarks
Even when hidden, the parameter can still be accessed directly via the API.
See Also