SlabShapeEditorAddPoint Method |
Add a point to the element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic SlabShapeVertex AddPoint(
XYZ point
)
Public Function AddPoint (
point As XYZ
) As SlabShapeVertex
public:
SlabShapeVertex^ AddPoint(
XYZ^ point
)
member AddPoint :
point : XYZ -> SlabShapeVertex
Parameters
- point XYZ
-
Return Value
SlabShapeVertex
the newly added slab shape vertex.
Exceptions
Remarks
The newly added point should be inside the element boundary on the x-y plane.
SlabShapeEditor must be enabled before calling this method.
Regenerate the document after element creation if this method is called in the same transaction.
See Also