SelectionFilterElementCreate Method

Creates a new SelectionFilterElement in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static SelectionFilterElement Create(
	Document document,
	string name
)

Parameters

document  Document
The document in which to create the SelectionFilterElement.
name  String
The name for the new SelectionFilterElement.

Return Value

SelectionFilterElement
The new SelectionFilterElement.
Exceptions
ExceptionCondition
ArgumentException name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a filter element name.
ArgumentNullException A non-optional argument was null
See Also