DocumentCombineElements Method |
Combine a set of combinable elements into a geometry combination.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic GeomCombination CombineElements(
CombinableElementArray members
)
Public Function CombineElements (
members As CombinableElementArray
) As GeomCombination
public:
GeomCombination^ CombineElements(
CombinableElementArray^ members
)
member CombineElements :
members : CombinableElementArray -> GeomCombination
Parameters
- members CombinableElementArray
- A list of combinable elements to be combined.
Return Value
GeomCombinationIf successful, the newly created geometry combination is returned, otherwise an
exception with error information will be thrown.
Exceptions
RemarksIf one or more existing geometry combinations are included as input, the return value may be one of those pre-existing
combinations. The rest of the pre-existing geometry combinations will be consumed into the new combination; those handles are no longer valid.
See Also