Transform2DIsTranslation Property |
The boolean value that indicates whether this transformation is a translation.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsTranslation { get; }
Public ReadOnly Property IsTranslation As Boolean
Get
public:
property bool IsTranslation {
bool get ();
}
member IsTranslation : bool with get
Property Value
Boolean
Remarks
This property is true if the only effect of transformation is translation.
It checks that the linear part of the transform is identity. The translation vector may be zero
(which would make this an identity transformation) or nonzero (which would make this a non-trivial translation).
See Also