NumberingSchemaSetMinimumNumberOfDigits Method

Sets a new value for the minimum number of digits to be used for formating the Number parameter of all numbered elements of the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void SetMinimumNumberOfDigits(
	Document document,
	int value
)

Parameters

document  Document
The document in which the new value will be in applied.
value  Int32
New value for the minimum number of digits.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The minimum number of digits must be in range from 1 to 10.
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
Remarks

Valid values range from 1 to 10. Numbers with fewer digits than the minimum number will be padded with leading zeros.

The value affects all numbering schemas. Thus, once set, numbers for Rebar and Reinforcement Fabric will be formatted with the same minimum number of digits.

The current value can obtained by invoking the GetMinimumNumberOfDigits(Document) method.

See Also