MEPAnalyticalConnectionTypeCreate Method |
Creates an analytical connection type element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static MEPAnalyticalConnectionType Create(
Document doc,
string name
)
Public Shared Function Create (
doc As Document,
name As String
) As MEPAnalyticalConnectionType
public:
static MEPAnalyticalConnectionType^ Create(
Document^ doc,
String^ name
)
static member Create :
doc : Document *
name : string -> MEPAnalyticalConnectionType
Parameters
- doc Document
-
The document.
- name String
-
The name of the analytical type to be created.
Return Value
MEPAnalyticalConnectionType
The created analytical connection type element.
ExceptionsException | Condition |
---|
ArgumentException |
This name is already used by an existing analytical connection type in the document.
-or-
name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
-or-
name is an empty string.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
The newly created type would have the default pressure loss being 0.
Use ElementType.duplicate to copy from any existing type.
See Also