ConditionType Enumeration |
An enumerated type listing all the possible condition types for a space object.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum ConditionType
Public Enumeration ConditionType
public enum class ConditionType
MembersMember name | Value | Description |
---|
Heated | 0 | Condition Type is Heated. |
Cooled | 1 | Condition Type is Cooled. |
HeatedAndCooled | 2 | Condition Type is HeatedAndCooled. |
Unconditioned | 3 | Condition Type is Unconditioned. |
Vented | 4 | Condition Type is Vented. |
NaturallyVentedOnly | 5 | Condition Type is NaturallyVentedOnly. |
NoOfConditionTypes | 6 | Condition Type is NoOfConditionTypes. |
See Also