ViewShapeBuilder(DirectShapeTargetViewType) Constructor |
A constructor for an ViewShapeBuilder object that takes a view type. It will infer the view normal from view type.
View normal and view type are used to validate the geometry to be stored as a view-specific shape representation of a DirectShape object.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ViewShapeBuilder(
DirectShapeTargetViewType targetViewType
)
Public Sub New (
targetViewType As DirectShapeTargetViewType
)
public:
ViewShapeBuilder(
DirectShapeTargetViewType targetViewType
)
new :
targetViewType : DirectShapeTargetViewType -> ViewShapeBuilder
Parameters
- targetViewType DirectShapeTargetViewType
-
View type for which this shape representation is intended. Currently limited to Plan Views.
Exceptions
See Also