Transform1D(Double) Constructor |
Constructs the transformation by specifying the scale only.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Transform1D(
double scale
)
Public Sub New (
scale As Double
)
public:
Transform1D(
double scale
)
new :
scale : float -> Transform1D
Parameters
- scale Double
-
The scale of the transformation.
Remarks
The translation is set to zero.
1D space is tranformed according to the following formula: t --> scale*t + translation
This constructor sets translation to zero.
See Also