FabricationServiceOverrideServiceButtonExclusion Method |
Overrides the default service button exclusions, used by Route and Fill, Design to Fabrication, or Multi Point Routing for the current user and session only.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void OverrideServiceButtonExclusion(
int paletteIndex,
int buttonIndex,
bool exclude
)
Public Sub OverrideServiceButtonExclusion (
paletteIndex As Integer,
buttonIndex As Integer,
exclude As Boolean
)
public:
void OverrideServiceButtonExclusion(
int paletteIndex,
int buttonIndex,
bool exclude
)
member OverrideServiceButtonExclusion :
paletteIndex : int *
buttonIndex : int *
exclude : bool -> unit
Parameters
- paletteIndex Int32
-
The index of the service palette to exclude the service button from.
- buttonIndex Int32
-
The index of the service button to exclude.
- exclude Boolean
-
Pass true to exclude from being used by Route and Fill or Design to Fabrication.
Exceptions
See Also