IndexStreamTriangleAddTriangle Method

Inserts a IndexTriangle into the stream and associated buffer.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddTriangle(
	IndexTriangle triangle
)

Parameters

triangle  IndexTriangle
The triangle to be inserted.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
InvalidOperationException Thrown if the associated buffer is not mapped. -or- Thrown if the associated buffer has insufficient space.
See Also