StructuralConnectionSettingsGetStructuralConnectionSettings Method

Obtains the StructuralConnectionSettings object for the specified project document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static StructuralConnectionSettings GetStructuralConnectionSettings(
	Document document
)

Parameters

document  Document
A project document.

Return Value

StructuralConnectionSettings
The StructuralConnectionSettings object.
Exceptions
ExceptionCondition
ArgumentException document is not a project document.
ArgumentNullException A non-optional argument was null
See Also