HostObjectUtilsGetSideFaces Method |
Returns the major side faces for this host object.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<Reference> GetSideFaces(
HostObject hostObject,
ShellLayerType side
)
Public Shared Function GetSideFaces (
hostObject As HostObject,
side As ShellLayerType
) As IList(Of Reference)
public:
static IList<Reference^>^ GetSideFaces(
HostObject^ hostObject,
ShellLayerType side
)
static member GetSideFaces :
hostObject : HostObject *
side : ShellLayerType -> IList<Reference>
Parameters
- hostObject HostObject
-
The host object.
- side ShellLayerType
-
The side of the host object.
Return Value
IListReference
An array of references to the faces which are on the given side of this element.
Exceptions
Remarks
This utility supports host objects whose CompoundStructure is nominally oriented vertically. It
outputs faces which are at the boundary of the CompoundStructure (such as Walls and FaceWalls).
See Also