ExternalResourceReference(Guid, IDictionaryString, String, String, String) Constructor |
Creates a new ExternalResourceReference from the given data.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ExternalResourceReference(
Guid serverId,
IDictionary<string, string> referenceInformation,
string version,
string inSessionPath
)
Public Sub New (
serverId As Guid,
referenceInformation As IDictionary(Of String, String),
version As String,
inSessionPath As String
)
public:
ExternalResourceReference(
Guid serverId,
IDictionary<String^, String^>^ referenceInformation,
String^ version,
String^ inSessionPath
)
new :
serverId : Guid *
referenceInformation : IDictionary<string, string> *
version : string *
inSessionPath : string -> ExternalResourceReference
Parameters
- serverId Guid
-
The id of the server associated with this
ExternalResourceReference. The server must implement
IExternalResourceServer.
- referenceInformation IDictionaryString, String
-
The (String, String) map containing reference or lookup information that will
be stored in Revit.
- version String
-
The version of the external data.
- inSessionPath String
-
The path that identifies a resource in server. ExternalResourceServer must provide this path which should not contain the server name.
Revit internally will construct and store the full display path which includes the server name plus this path at the time a resource
is loaded into the model for use if the server is missing.
Exceptions
See Also