GlobalParameterGetValue Method

Obtains the curent value of the global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ParameterValue GetValue()

Return Value

ParameterValue
An instance of one of the classes derived from the ParameterValue base class.
Remarks

Note that a value is always returned regardless of whether the parameter is formula-driven, or dimension-driven, or independent.

The returned ParameterValue is casted-up an instance of one of the derived classes, such as DoubleParameterValue or IntegerParameterValue.

See Also