InsertOrientation Enumeration |
The allowed values for the INSERT_ORIENTATION parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum InsertOrientation
Public Enumeration InsertOrientation
public enum class InsertOrientation
MembersMember name | Value | Description |
---|
Vertical | 0 |
Insert is vertical regardless of the wall's slant.
|
Slanted | 1 |
Insert is aligned with the Slanted wall's slant direction.
|
Exterior | 2 |
Insert is aligned with the Tapered wall's exterior face.
|
Interior | 3 |
Insert is aligned with the Tapered wall's interior face.
|
See Also