DocumentConvertModelToDetailCurves Method |
Converts a group of ModelCurves to equivalent DetailCurves.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic DetailCurveArray ConvertModelToDetailCurves(
View view,
ModelCurveArray modelCurves
)
Public Function ConvertModelToDetailCurves (
view As View,
modelCurves As ModelCurveArray
) As DetailCurveArray
public:
DetailCurveArray^ ConvertModelToDetailCurves(
View^ view,
ModelCurveArray^ modelCurves
)
member ConvertModelToDetailCurves :
view : View *
modelCurves : ModelCurveArray -> DetailCurveArray
Parameters
- view View
- The view where the new lines will be created.
The lines are projected on the view plane.
If the lines are not parallel to the view plane, lines are foreshortened and arcs are converted to ellipses.
Splines are modified.
- modelCurves ModelCurveArray
- The model curve array to be converted.
Return Value
DetailCurveArray
ExceptionsException | Condition |
---|
ArgumentNullException |
Thrown when the input argument is .
|
ArgumentException |
Thrown when view is invalid to create DetailCurves on it.
|
InvalidOperationException |
Thrown when current document is a family.
Thrown when one or more curves could not be successfully converted, perhaps because some of the input curves could not be projected onto the active workplane of the view.
|
RemarksThis operation will create new DetailCurves with the same geometry of the original model curves' geometry. The model curves will be deleted from the document.
If the model curves do not lie in a plane parallel to the view, their geometry will be projected to the view.
See Also