IMultiServerServiceCanExecute Method |
Implement this to test whether a particular server should be executed.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxbool CanExecute(
IExternalServer server,
Document document,
IExternalData data
)
Function CanExecute (
server As IExternalServer,
document As Document,
data As IExternalData
) As Boolean
bool CanExecute(
IExternalServer^ server,
Document^ document,
IExternalData^ data
)
abstract CanExecute :
server : IExternalServer *
document : Document *
data : IExternalData -> bool
Parameters
- server IExternalServer
-
An instance of a server that is to be tested.
- document Document
-
The associated document. It may be NULL if not applicable.
- data IExternalData
-
The associated service data. It is the same data the Execute method would receive.
Return Value
Boolean
See Also