AnalyticalMemberSetMemberForces(MemberForces) Method

Sets Member Forces to Analytical Member.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetMemberForces(
	MemberForces memberForces
)

Parameters

memberForces  MemberForces
End to which member forces will be added is defined by setting [!:Autodesk::Revit::DB::Structure::MemberForces::Position] property in provided Member Forces object.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
Remarks
If element already have member forces defined for that end, newly provided values replace current one. Member forces are strictly related with releases. This means that setting member forces values is reasonable only for directions that have releases set to false.
See Also