SlabShapeEditorAddPoints Method |
Add an array of points to the element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<SlabShapeVertex> AddPoints(
IList<XYZ> points
)
Public Function AddPoints (
points As IList(Of XYZ)
) As IList(Of SlabShapeVertex)
public:
IList<SlabShapeVertex^>^ AddPoints(
IList<XYZ^>^ points
)
member AddPoints :
points : IList<XYZ> -> IList<SlabShapeVertex>
Parameters
- points IListXYZ
-
The point array.
Return Value
IListSlabShapeVertex
The newly added slab shape vertices.
Exceptions
Remarks
The newly added points should be distinct on the x-y plane, and they should be inside the element boundary.
SlabShapeEditor must be enabled before calling this method.
Regenerate the document after element creation if this method is called in the same transaction.
See Also