MechanicalSystemGetStaticPressure Method |
Gets the static pressure of this mechanical system.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double GetStaticPressure()
Public Function GetStaticPressure As Double
public:
double GetStaticPressure()
member GetStaticPressure : unit -> float
Return Value
Double
Exceptions
Remarks
The system static pressure is calculated in the non-blocking evaluation framework. The caller may set up callbacks that react to the asynchronous calculation results.
If no callback is set up (e.g, called from third-party applications), the calculation is automatically switched to synchronous calculation so the caller
can access the up-to-date result. Similarly, the public method get_ParameterValue(BuiltInParameter.RBS_DUCT_STATIC_PRESSURE) has the same behavior. Due to this
change, the parameter RBS_DUCT_STATIC_PRESSURE no longer supports dynamic model update.
See Also