Transform2DMultiply Method |
Multiplies this transformation by the specified transformation and returns the result.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Transform2D Multiply(
Transform2D right
)
Public Function Multiply (
right As Transform2D
) As Transform2D
public:
Transform2D^ Multiply(
Transform2D^ right
)
member Multiply :
right : Transform2D -> Transform2D
Parameters
- right Transform2D
-
Return Value
Transform2D
The transformation equal to the composition of the two transformations.
Exceptions
Remarks
The combined transformation has the same effect as applying the right transformation first, and this transformation, second.
So, denoting this transform by T1 and the right transform by T2, (T1(T2(p)) = (T1 * T2) (p).
See Also