IFCCategoryTemplateCopyTemplate Method

Create copy of mapping template with new name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IFCCategoryTemplate CopyTemplate(
	Document document,
	string copyTemplateName
)

Parameters

document  Document
A Revit document.
copyTemplateName  String
A name for copied template name.

Return Value

IFCCategoryTemplate
The copied mapping template element.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
InvalidOperationException Failed to create IFCCategoryTemplate element.
See Also