IFamilyLoadOptionsOnFamilyFound Method |
A method called when the family was found in the target document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxbool OnFamilyFound(
bool familyInUse,
out bool overwriteParameterValues
)
Function OnFamilyFound (
familyInUse As Boolean,
<OutAttribute> ByRef overwriteParameterValues As Boolean
) As Boolean
bool OnFamilyFound(
bool familyInUse,
[OutAttribute] bool% overwriteParameterValues
)
abstract OnFamilyFound :
familyInUse : bool *
overwriteParameterValues : bool byref -> bool
Parameters
- familyInUse Boolean
-
Indicates if one or more instances of the family is placed in the project.
- overwriteParameterValues Boolean
-
This determines whether or not to overwrite the parameter
values of existing types. The default value is false.
Return Value
Boolean
Return true to continue loading the family, false to cancel.
Remarks
Triggered only when the family is both loaded and changed.
See Also