ReinforcementSettingsRebarPresentationInSection Property |
The default presentation mode for rebar sets, when:
- The view direction is perpendicular to the rebar normal and the rebar set is cut.
- The view direction is not perpendicular to the rebar normal and the view direction is not parallel to the rebar normal.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarPresentationMode RebarPresentationInSection { get; set; }
Public Property RebarPresentationInSection As RebarPresentationMode
Get
Set
public:
property RebarPresentationMode RebarPresentationInSection {
RebarPresentationMode get ();
void set (RebarPresentationMode value);
}
member RebarPresentationInSection : RebarPresentationMode with get, set
Property Value
RebarPresentationMode
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
Remarks
All bars in a given rebar set will be visible if:
- The view is a 3D view.
- The view direction is not parallel to the rebar normal.
For this case there are no defaults and no overrides in instances.
See Also