RebarConstraintCreateConstraintToSurface Method |
This method creates a constraint of 'To Surface' type for a given RebarConstrainedHandle.
The RebarConstrainedHandle should belong to a shape driven rebar, otherwise it will throw exception.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static RebarConstraint CreateConstraintToSurface(
RebarConstrainedHandle handle,
Surface surface
)
Public Shared Function CreateConstraintToSurface (
handle As RebarConstrainedHandle,
surface As Surface
) As RebarConstraint
public:
static RebarConstraint^ CreateConstraintToSurface(
RebarConstrainedHandle^ handle,
Surface^ surface
)
static member CreateConstraintToSurface :
handle : RebarConstrainedHandle *
surface : Surface -> RebarConstraint
Parameters
- handle RebarConstrainedHandle
-
The handle of the rebar that will be constrained.
- surface Surface
-
The surface that will be used by the constraint.
Return Value
RebarConstraint
Returns the newly created RebarConstraint.
Exceptions
See Also