DocumentEraseSchemaAndAllEntities Method |
Erases Schema and all its Entities from the document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void EraseSchemaAndAllEntities(
Schema schema
)
Public Sub EraseSchemaAndAllEntities (
schema As Schema
)
public:
void EraseSchemaAndAllEntities(
Schema^ schema
)
member EraseSchemaAndAllEntities :
schema : Schema -> unit
Parameters
- schema Schema
-
The Schema to erase.
Exceptions
Remarks
The Schema remains in memory.
Any schema the schema is a sub-schema for will not be impacted.
All data referenced by the schema as the result of being a sub-schema will remain in the document.
See Also