FamilyInstanceStructuralType Property |
Provides the primary structural type of the instance, such as beam or column etc.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic StructuralType StructuralType { get; }
Public ReadOnly Property StructuralType As StructuralType
Get
public:
property StructuralType StructuralType {
StructuralType get ();
}
member StructuralType : StructuralType with get
Property Value
StructuralType
Examplepublic void GetStructuralType(FamilyInstance familyInstance)
{
string message = "";
switch (familyInstance.StructuralType)
{
case StructuralType.Beam:
message = "FamilyInstance is a beam.";
break;
case StructuralType.Brace:
message = "FamilyInstance is a brace.";
break;
case StructuralType.Column:
message = "FamilyInstance is a column.";
break;
case StructuralType.Footing:
message = "FamilyInstance is a footing.";
break;
default:
message = "FamilyInstance is non-structural or unknown framing.";
break;
}
TaskDialog.Show("Revit",message);
}
Public Sub GetStructuralType(familyInstance As FamilyInstance)
Dim message As String = ""
Select Case familyInstance.StructuralType
Case StructuralType.Beam
message = "FamilyInstance is a beam."
Exit Select
Case StructuralType.Brace
message = "FamilyInstance is a brace."
Exit Select
Case StructuralType.Column
message = "FamilyInstance is a column."
Exit Select
Case StructuralType.Footing
message = "FamilyInstance is a footing."
Exit Select
Case Else
message = "FamilyInstance is non-structural or unknown framing."
Exit Select
End Select
TaskDialog.Show("Revit", message)
End Sub
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also