ParameterSetMultiple Method |
Sets multiple parameters to new values.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static List<Parameter> SetMultiple(
IList<Tuple<Parameter, ParameterValue>> values
)
Public Shared Function SetMultiple (
values As IList(Of Tuple(Of Parameter, ParameterValue))
) As List(Of Parameter)
public:
static List<Parameter^>^ SetMultiple(
IList<Tuple<Parameter^, ParameterValue^>^>^ values
)
static member SetMultiple :
values : IList<Tuple<Parameter, ParameterValue>> -> List<Parameter>
Parameters
- values IListTupleParameter, ParameterValue
- A list of pairs of parameters and their corresponding values.
Return Value
ListParameterThe list of parameters that were not set successfully, if any.
Exceptions
RemarksThis method is provided as a performance optimization. Note that it will throw an
exception if any parameter would throw an exception, so validate ahead of time.
See Also