RebarConstraintsManagerGetPreferredConstraintOnHandle Method |
For ShapeDriven: Returns the RebarConstraint that has been set as preferred for the specified RebarConstrainedHandle.
For FreeForm: Returns the RebarConstraint that acts on the specified RebarConstraintHandle.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarConstraint GetPreferredConstraintOnHandle(
RebarConstrainedHandle handle
)
Public Function GetPreferredConstraintOnHandle (
handle As RebarConstrainedHandle
) As RebarConstraint
public:
RebarConstraint^ GetPreferredConstraintOnHandle(
RebarConstrainedHandle^ handle
)
member GetPreferredConstraintOnHandle :
handle : RebarConstrainedHandle -> RebarConstraint
Parameters
- handle RebarConstrainedHandle
-
The RebarConstrainedHandle for which the RebarConstraint is to be returned.
Return Value
RebarConstraint
The user preferred RebarConstraint applied to the RebarConstrainedHandle.
Exceptions
See Also