DetachFromCentralOption Enumeration |
Options for workset detachment behavior.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum DetachFromCentralOption
Public Enumeration DetachFromCentralOption
public enum class DetachFromCentralOption
type DetachFromCentralOption
MembersMember name | Value | Description |
---|
DoNotDetach | 0 |
Do not detach the file being opened from its central file.
|
DetachAndPreserveWorksets | 1 |
Detach the file being opened from its central file.
|
DetachAndDiscardWorksets | 2 |
Detach the model being opened from its central model and discard worksets/worksharing.
|
ClearTransmittedSaveAsNewCentral | 3 |
After opening the transmitted, workshared model, immediately resave it with its current name
and clear the transmitted flag.
|
See Also