ReferencePointPosition Property |
The position of the ReferencePoint.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic XYZ Position { get; set; }
Public Property Position As XYZ
Get
Set
public:
property XYZ^ Position {
XYZ^ get ();
void set (XYZ^ value);
}
member Position : XYZ with get, set
Property Value
XYZ
ExceptionsException | Condition |
---|
InvalidOperationException |
Thrown when CoordinateSystem is set while the Reference
property is not , and the ReferencePoint is unable to
move to the new location.
|
RemarksThis is an alternate interface to the property
CoordinateSystem.Origin. When set, the effect is the same
as setting the CoordinateSystem property to the same as
its current value but with a different Origin.
See Also