AnalyticalSurfaceBaseIsCurveLoopValid Method |
Note: This API is now obsolete.
Checks if curve loop is valid for Analytical Surface.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax[ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a later version of Revit. We suggest you use the 'IsOuterContourValid' method instead.")]
public static bool IsCurveLoopValid(
CurveLoop profile
)
<ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a later version of Revit. We suggest you use the 'IsOuterContourValid' method instead.")>
Public Shared Function IsCurveLoopValid (
profile As CurveLoop
) As Boolean
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2025 and may be removed in a later version of Revit. We suggest you use the 'IsOuterContourValid' method instead.")]
static bool IsCurveLoopValid(
CurveLoop^ profile
)
[<ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a later version of Revit. We suggest you use the 'IsOuterContourValid' method instead.")>]
static member IsCurveLoopValid :
profile : CurveLoop -> bool
Parameters
- profile CurveLoop
-
The curve loop to be checked.
Return Value
Boolean
Returns true if curve loop is ok, false otherwise.
Exceptions
See Also