RebarConstraintIsValidSurfaceToConstraintHandleTo Method |
Checks if the surface can be used to create a constraint to it for the input handle.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidSurfaceToConstraintHandleTo(
RebarConstrainedHandle handle,
Surface surface
)
Public Shared Function IsValidSurfaceToConstraintHandleTo (
handle As RebarConstrainedHandle,
surface As Surface
) As Boolean
public:
static bool IsValidSurfaceToConstraintHandleTo(
RebarConstrainedHandle^ handle,
Surface^ surface
)
static member IsValidSurfaceToConstraintHandleTo :
handle : RebarConstrainedHandle *
surface : Surface -> bool
Parameters
- handle RebarConstrainedHandle
-
The handle of the rebar that will be constrained.
- surface Surface
-
The surface that will be tested.
Return Value
Boolean
Returns true if the surface can be used to create a constraint to it for the input handle.
Exceptions
RemarksIf the handle belongs to a free from rebar will return false.
If the input plane is almost perpendicular (the angle between surfaces is between 84 or 96 degrees) will return false.
If the input handle is Rebar Plane or Out Of Plane Extents and the surface isn't a plane will return false.
If the input handle is a segment of a bar whose shape has a RebarShapeDefinitionBySegments definition and the surface isn't a cylinder surface will return false.
For any other cases will return true
See Also