RebarShapeDefinitionBySegments Constructor |
Create a rebar shape definition with a given number of segments.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarShapeDefinitionBySegments(
Document doc,
int numberOfSegments
)
Public Sub New (
doc As Document,
numberOfSegments As Integer
)
public:
RebarShapeDefinitionBySegments(
Document^ doc,
int numberOfSegments
)
new :
doc : Document *
numberOfSegments : int -> RebarShapeDefinitionBySegments
Parameters
- doc Document
-
A document. The definition object is not a part of the document,
but it will contain references to parameters that are in a document.
The definition can be used for RebarShape creation only in the
specified document.
- numberOfSegments Int32
-
The number of segments in the definition.
Exceptions
See Also