This enumeration is used for specifying the most predominant building use type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxPublic Enumeration BuildingType
public enum class BuildingType
MembersMember name | Value | Description |
---|
kAutomotiveFacility | 0 | Building Type is AutomotiveFacility. |
kConventionCenter | 1 | Building Type is ConventionCenter. |
kCourthouse | 2 | Building Type is Courthouse. |
kDiningBarLoungeOrLeisure | 3 | Building Type is DiningBarLoungeOrLeisure. |
kDiningCafeteriaFastFood | 4 | Building Type is DiningCafeteriaFastFood. |
kDiningFamily | 5 | Building Type is DiningFamily. |
kDormitory | 6 | Building Type is Dormitory. |
kExerciseCenter | 7 | Building Type is ExerciseCenter. |
kFireStation | 8 | Building Type is FireStation. |
kGymnasium | 9 | Building Type is Gymnasium. |
kNoOfBuildingTypes | -1 | Building Type is NoOfBuildingTypes. |
kHospitalOrHealthcare | 10 | Building Type is HospitalOrHealthcare. |
kHotel | 11 | Building Type is Hotel. |
kLibrary | 12 | Building Type is Library. |
kManufacturing | 13 | Building Type is Manufacturing. |
kMotel | 14 | Building Type is Motel. |
kMotionPictureTheatre | 15 | Building Type is MotionPictureTheatre. |
kMultiFamily | 16 | Building Type is MultiFamily. |
kMuseum | 17 | Building Type is Museum. |
kOffice | 18 | Building Type is Office. |
kParkingGarage | 19 | Building Type is ParkingGarage. |
kPenitentiary | 20 | Building Type is Penitentiary. |
kPerformingArtsTheater | 21 | Building Type is PerformingArtsTheater. |
kPoliceStation | 22 | Building Type is PoliceStation. |
kPostOffice | 23 | Building Type is PostOffice. |
kReligiousBuilding | 24 | Building Type is ReligiousBuilding. |
kRetail | 25 | Building Type is Retail. |
kSchoolOrUniversity | 26 | Building Type is SchoolOrUniversity. |
kSportsArena | 27 | Building Type is SportsArena. |
kTownHall | 28 | Building Type is TownHall. |
kTransportation | 29 | Building Type is Transportation. |
kWarehouse | 30 | Building Type is Warehouse. |
kWorkshop | 31 | Building Type is Workshop. |
Remarks
This enumerated list corresponds to the buildingType attribute in the gbXML (Green Building XML) schema
and is primarily used for energy analysis.
See Also