AnalyticalElementIsValidTransform Method |
Checks whether the value set for Local Coordinate System is valid for an Analytical Element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValidTransform(
Transform trf
)
Public Function IsValidTransform (
trf As Transform
) As Boolean
public:
bool IsValidTransform(
Transform^ trf
)
member IsValidTransform :
trf : Transform -> bool
Parameters
- trf Transform
-
The value set to be verified.
Return Value
Boolean
Exceptions
Remarks
Origin should be equal with Origin from
GetTransform
Z axis should be parallel with Analytical Element's plane.
X and Y axis should be in Analytical Element's plane.
For non-planar elements the X or Y axis should be tangent at transform origin.
See Also