SchemaBuilderSetVendorId Method

Sets the ID of the third-party vendor that may access entities of this Schema under the Vendor acess level, and to generally identify the owner of this Schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public SchemaBuilder SetVendorId(
	string vendorId
)

Parameters

vendorId  String
The vendor id.

Return Value

SchemaBuilder
The SchemaBuilder object may be used to add more settings.
Exceptions
ExceptionCondition
ArgumentException The vendorId is invalid.
ArgumentNullException A non-optional argument was null
InvalidOperationException The SchemaBuilder has already finished building the Schema.
Remarks
This method throws an ArgumentException if the given vendor ID string is not valid. To understand the validity requirements for vendor ID strings, see the documentation for the ESSchemaBuilder method vendorIdIsValid(). Since vendor IDs are not case sensitive, the string will be converted to upper case before it is stored in the schema.
See Also