Returns the signed volume of this solid.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double Volume { get; }
Public ReadOnly Property Volume As Double
Get
public:
property double Volume {
double get ();
}
member Volume : float with get
Return Value
DoubleThe real number equal to the signed volume of this solid.
ExceptionsException | Condition |
---|
InvalidOperationException |
Thrown when this solid is not a valid Geometry object or the volume calculation failed.
|
Remarks
Revit attempts to compute the volume analytically, if possible. If an analytical solution is not possible,
it uses tessellated faces to calculate a reasonable approximation for the volume.
The calculated volume may be slightly underestimated or overestimated if curved surfaces are present.
See Also