SpatialElementTagTagHeadPosition Property |
The position of the tag's head.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic XYZ TagHeadPosition { get; set; }
Public Property TagHeadPosition As XYZ
Get
Set
public:
property XYZ^ TagHeadPosition {
XYZ^ get ();
void set (XYZ^ value);
}
member TagHeadPosition : XYZ with get, set
Property Value
XYZ
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: Head position of the tag with no leader could not be located outside of the host element.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
InvalidOperationException |
When setting this property: SpatialElementTag is pinned.
-or-
When setting this property: SpatialElementTag is orphaned.
|
Remarks
Returns the end point of the tag leader.
Leader end point must be located inside of a room, space or an area.
Use Room.IsPointInRoom or Space.IsPointInSpace method to check whether the leaderEnd is located in the host element or not.
See Also