RebarShapeDefinitionBySegmentsAddBendDefaultRadius Method

Specify a default-radius bend.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddBendDefaultRadius(
	int vertexIndex,
	RebarShapeVertexTurn turn,
	RebarShapeBendAngle angle
)

Parameters

vertexIndex  Int32
Index of the vertex (1 to NumberOfVertices - 2).
turn  RebarShapeVertexTurn
Specify turn direction (RebarShapeVertexTurn::Left or RebarShapeVertexTurn::Right).
angle  RebarShapeBendAngle
Specify whether the bend is acute, obtuse, etc.
Exceptions
ExceptionCondition
ArgumentException vertexIndex is not between 0 and NumberOfVertices.
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks
You must add a bend at each vertex except the first and last.
See Also