AnalyticalLinkTypeIsValidAnalyticalFixityState Method

Returns whether the input fixity state is valid for Analytical Link Type parameters.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsValidAnalyticalFixityState(
	AnalyticalFixityState fixityState
)

Parameters

fixityState  AnalyticalFixityState
The fixity state value to check.

Return Value

Boolean
True if valid.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also